• June 2019
 

LineageOS 15 for Moto X Pure (Style) – Android Oreo

Rate this content

CyanogenMod ROM Forums Motorola Device Forums Motorola Moto X Pure – clark LineageOS 15 for Moto X Pure (Style) – Android Oreo

This topic contains 18 replies, has 6 voices, and was last updated by  shibaa987 10 months ago.

 
 
Viewing 9 posts - 11 through 19 (of 19 total)
  • Author
    Posts
  • #38293

    shibaa987
    Participant

    You can only flash the above stock firmware using fastboot utility.
    This cannot be flashed using TWRP recovery.

    I have updated the above lines of fastboot commands so that the bootloader will NOT be locked.

    #38499

    nope
    Member

    I followed the commands but received the following at “fastboot flash modem NON-HLOS.bin”

    target reported max download size of 536870912 bytes
    sending ‘modem’ (41725 KB)…
    OKAY [ 0.882s]
    writing ‘modem’…
    (bootloader) Preflash validation failed
    FAILED (remote failure)
    finished. total time: 0.917s

    All remaining and prior commands worked. Does this mean that my previous modem was not overwritten? Before proceeding with attempting to flash TWRP and then the LOS 15.1 rom I want to make sure I correct any problems.

    #38578

    nope
    Member

    I got tired of waiting for a response and flashed TWRP and LineageOS 8.1 5/13. That was successful this time. You might want to note in your instructions that anyone with my bootloader version will have to upgrade to a newer version before flashing LineageOS 8.1

    #42165

    joheli
    Member

    problems with bootloader-flash

    After testing the last lineageOS-version I wanted to go back to stock-nougat to have a working camera for vacations. However there was a problem with flashing the gpt.bin and bootloader.img. I got a “moto boot prevalidation flash (FAILED) remote failure” as a result. After researching the error on google I read about other people having this problem, but that it is possible to continue without flashing the bootloader. Indeed, the ROM booted succesfully and everything seemed to normal. After a while I noticed that the simcard wouldn’t be recongnized even after several reboots. It turned out that my phone had forgotten it’s IMEI and BASEBAND-numbers (Bootloader: “BASEBAND:<unknown>”, Settings: “IMEI: unknown”) I tried to reflash any of my TWRP-backups and reflashed both the stock- and LOS-ROMs but the SIM would not work again. I’ve read some guides on “how to restore IMEI/Baseband” but they all say “try flashing the stock ROM”. Is there any way of reflashing my current bootloader (version Ax0.52) to flash a full stock ROM or any other way to recover IMEI/Baseband-version?

    #44132

    falcon369
    Member

    Hello,
    Sorry for any disturbing but, there is a problem the camera isn’t working on my phone. Can you please fix this problem? I installed the rom correctly.

    #44475

    shibaa987
    Participant

    @elias_wetzel

    Looks like either there is no modem image or it is corrupted or might be a mismatch with bootloader.
    Yes, if you flash the stock ROM, it should be fixed. If not, do clean all the images before installing a new firmware on your phone.

    #44574

    falcon369
    Member

    I did what you said but, the same result. The camera still not working and the status bar 3 clock widgets?
    Is the problem because of my gapps or I didn’t flash the root file to my device? Flashing my stock rom the camera is working fine but, flashing this rom the camera isn’t working. Is this a bug?

    #44612

    joheli
    Member

    @shibaa987

    thanks for your hekp, but I couldn’t follow completely

    1. what exactly do you mean by “ceaning all the images”? I tried to wipe the phone via TWRP multiple times with no success

    2. my real problem is, that I’m not able to flash a full stock ROM due to the mentioned preflash validation error

    #44814

    shibaa987
    Participant

    preflash validation fails due to the locked bootloader.

    Either unlock bootloader on Motorola phone to skip boot flash validation checks

    OR flash stock factory image without unlocking bootloader using the stock recovery mode.
    So, it should be Standard recovery and factory firmware image

 
 
Viewing 9 posts - 11 through 19 (of 19 total)

You must be logged in to reply to this topic.

   
Loading...