Honor 5x LineageOS 14.1, Nougat 7.1 ROM

CyanogenMod ROM Forums Huawei Device Forums Honor 5x – kiwi Honor 5x LineageOS 14.1, Nougat 7.1 ROM

  • This topic has 5 replies, 4 voices, and was last updated 3 years ago by kr16.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #11871

    Here comes the OFFICIAL Huawei Honor 5x LineageOS 14.1 ROM build. If you want some more Lineage ROMs then stay tuned to the LineageOS 14.1 ROM collection page. Before this there was the CM14.1 for Honor 5x.

    THIS IS AN INITIAL NIGHTLY BUILD WHICH MAY HAVE BUGS. HAVE A BACKUP OF THE CURRENT ROM BEFORE FLASHING THIS ROM AND TRY AT YOUR OWN RISK. Installing a custom ROM on a Honor 5x (kiwi) requires the bootloader to be unlocked on the Honor 5x (kiwi) phone, which may VOID your warranty and may delete all your data. Before proceeding further you may consider backup all data on the phone. You are the only person doing changes to your phone and I cannot be held responsible for the mistakes done by you.

    Upgrading from Honor 5x CyanogenMod 14.1 to LineageOS 14.1:

    Lineage developer team will be releasing EXPERIMENTAL builds along with weekly NIGHTLY build so that users can migrate from CM14.1 to LineageOS 14.1 easily. Here is a guide that explains how to migrate CM14.1 to LineageOS 14.1.

    Honor 5x LineageOS 14.1 NOUGAT CUSTOM ROM


    Root binary is inbuilt in LineageOS 14.1, so you don’t need a separate SuperSu package to install to gain ROOT access. Here is How to Enable ROOT on LineageOS 14.1
    If there is no in-built ROOT or it does not work for some reason then you can try flashing SuperSU zip using recovery to gain ROOT access.


    1. Follow this if you are flashing LineageOS 14.1 for Honor 5x (kiwi) for the first time, or coming from another ROM:

      Points to NOTE:
      – Try to avoid restoring apps backup using Titanium Backup. It may break things up.
      – Don’t restore system data using Titanium Backup! It will definitely break the current installation.
      – It is also discouraged to Restoring Apps + Data using Titanium Backup.

    2. Upgrading from earlier version of LineageOS 14.1 for Honor 5x (kiwi):

    Complete the initial setup and enjoy Android Nougat 7.1 with LineageOS 14.1 for Honor 5x (kiwi). After the installation of LineageOS 14.1 for Honor 5x (kiwi) you may want to enable ROOT access on your phone and here is how you can do that:
    How to Enable ROOT on LineageOS 14.1.

    Stay tuned or Subscribe to the Honor 5x (kiwi) forum For other Android Nougat ROMs, LineageOS 14.1 ROMs, other ROMs and all other device specific topics.



    I installed the version on my 5X, only to find boot loop from booting. My 5X keeps restarting always.

    Do you have any possible ways to solve this?




    Running 2017-02-22 Nightly on my 5X and it’s working great, including the fingerprint scanner. Thanks very much!

    Just a few notes from my installation experience

    • I got an error in TWRP when I tried to install on EMUI 3. Sorry, don’t remember the exact error. I had to upgrade to EMUI 4 before it would work. I was installing on a new phone and it came with EMUI3.
    • The OEM recovery is very persistent, I couldn’t get TWRP to load even after erasing recovery and flashing multiple times. I had to use fastboot boot twrp.x.x.x-kiwi.img from the bootloader to get it working.
    • One of the instructions I read said to wipe the phone, restart, install the Lineage rom, restart, then install google apps, restart. That didn’t work for me, I got stuck in in the setup wizard with an error: “Setup wizard has stopped working.” I then wiped the phone, installed Lineage and installed gapps (stock), all in one step. It worked perfectly.

    Hi, thanks for your instruction. I followed your case, and still got stuck. I have to look into it deeper.


    OK. After spending few hours on googling and reading I finally get it to work 🙂

    Only thing that failed for me was zip verification of lineage ROM ( i tried 2017/03/01 and 2017/02/22)
    After I turn off zip verification it went through OK.

    I followed above instructions step by step.
    Phone just booted and I was able to set fingerprints and setup google account.
    So far so good. Will test some more for next few days.

    PS. How the hell do I turn off second sim card? (I got two numbers -two sim cards- but I only use one in US)


    Today I installed root binary provided for LineageOS and again zip verification failed.
    Had to turn it off and it installed correctly.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.