Savitar, one of the GCam dev, raising funds for his father's medical expenses.
Please donate him via GoFundMe or PayPal
 

Download LineageOS 16 for Galaxy J5 – All Variants

Viewing 4 posts - 11 through 14 (of 14 total)
 
 
 
  • Author
    Posts
  • #100490
    xX_m3m3l0rd_Xx
    Participant

    [postquote quote=100489][/postquote]

    My device is SM-500H

    #101153
    unobtanium
    Participant

    Hello, thank you for this ROM!

    I am a beginner when it comes to flashing ROMs.
    I have successfully installed this ROM on my J500FNXXU1BPL5.
    However I then tried to do the same on a J500FNXXU1APD1 and I am unable to get it working.

    On both devices I had to use a custom TWRP Version for the J5s which I found here: https://forum.xda-developers.com/galaxy-j5/development/recovery-samsung-galaxy-j5-t3338869

    It seemed I had to use the TWRP versions for j5nltexx instead of j5nlte (which – I assume – makes sense since the phones are fnxx versions). On the first phone (BPL5) I was later able to flash the latest, official TWRP 3.2.3 j5nlte version from within the custom TWRP 3.0.2 j5nltexx. I had to do that because the custom 3.0.2 TWRP version was unable to install LinageOS because it failed with error code 7. It seemed like it was unable to read the build version of the phone because the assert failed and said “E3004: This package is for device: j5nlte, j5nltexx; this device is . Updater process ended with ERROR: 7” I got that fixed on the first phone by installing the offical version I mentioned earlier and then the installation went through just fine.

    However I then tried to do the same on the APD1 phone (I assume a slightly older version) and I was able to install the TWRP 3.0.2 j5nltexx, but unable to flash the 3.2.3 j5nlte one to get rid of the error code 7 (or any j5nlte TWRP version I could get my hands on, it always showed a black screen when trying to load into recovery mode and had to flash the 3.0.2 via download mode and Odin again). I then was able to flash the official TWRP 3.1.1 j5nltexx version however, got the same error code 7 message again. I then made the desperation move and deleted the assert code lines in the updater-script file and it seemed like it successfully installed LinageOS and GApps. However on system startup the displayed stayed black (similar to the black screen when trying to load into recovery mode).

    I assume the TWRP versions and the LinageOS is not suited for this J500FNXXU1APD1 device type? I also read somewhere that some TWRP versions had a bug that the backlight did not turn on on some devices which also resulted in seemingly black screens, however I was unable to test that theory.

    At this point I gave up and restored a previous backup but would still like to also install LinageOS on the second phone and want to know from an expert what caused the installation to fail and if the slight difference in phone difference might be the main cause or if I just messed something up somewhere. I am certain I wiped the partitions on both phones. The only difference I can think of at this point was that I performed a Factory Reset on the first phone and it updated from Android 5 to Android 6 and the second phone was Android 5 and I did not perform a Factory Reset. However, I assume this does not matter since I do a wipe from within TWRP anyways prior and should not effect installation in any way.

    I would appreciate any help I can get.
    Thanks in advance!
    unobtanium

    #103017
    unobtanium
    Participant

    Any idea on how I can resolve this?
    I still would like to have LinageOS 16 installed on the other smartphone as well.

    #103476
    unobtanium
    Participant

    It seems I have solved it. I think the issue got resolved when I reset to the old samsung android 5.1 version and made an system update to the samsung android 6.0 version. This somehow updated the version numbers from J500FNXXU1APD1 to J500FNXXU1BPL5 and it made me install the LineageOS 16 just fine.

Viewing 4 posts - 11 through 14 (of 14 total)
 
 
 
  • You must be logged in to reply to this topic.