• September 2019
 

Download and Install LineageOS 16 on Nexus 9 – flounder

CyanogenMod ROM Forums Google Device Forums Nexus 9 – flounder Download and Install LineageOS 16 on Nexus 9 – flounder

This topic contains 25 replies, has 11 voices, and was last updated by  siba 4 months ago.

 
 
Viewing 10 posts - 11 through 20 (of 26 total)
  • Author
    Posts
  • #44813

    shibaa987
    Participant

    I think the TWRP asks for the password because of encryption.
    I will give you more data on this.

    @cblx5

    You can either flash another ROM or you can go back to stock Nexus 9 FW by flashing the stock images:
    https://developers.google.com/android/images#volantis

    You can follow the following guide: How to flash Nexus stock firmware

    #44902

    cblx5
    Member

    Hi shibaa987,

    I downloaded latest stock ROM for Nexus 9 WIFI which is 7.1.1 (N9F27M, Oct 2017)

    I tried the flash.bat which failed to complete so manually tried your steps

    I am sure the “fastboot flash bootloader bootloaderXXXXXXXX.img” command worked as the Nexus is reporting HBOOT-3.50.0.0143

    I ignored radio as I have no phone capability.

    However when I run “fastboot flash system system.img” it never completes ….. see cmd( DOS) extract below:

    Please note system.img is 1.5 GB and other numbers are 0.5 GB approx..

    Can I do anything to fix please ?

    Directory of C:\…..\volantis-n9f27m\image-volantis-n9f27m

    18/08/2018 20:39 <DIR> .
    18/08/2018 20:39 <DIR> ..
    18/08/2018 20:39 67 android-info.txt
    18/08/2018 20:39 8,829,440 boot.img
    18/08/2018 20:39 6,398,184 cache.img
    18/08/2018 20:39 11,459,072 recovery.img
    18/08/2018 20:39 1,523,831,228 system.img
    18/08/2018 20:39 128,370,260 vendor.img
    6 File(s) 1,678,888,251 bytes
    2 Dir(s) 384,290,828,288 bytes free

    C:\……….\image-volantis-n9f27m>fastboot flash system system.img
    target reported max download size of 518205818 bytes
    erasing ‘system’…
    OKAY [ 0.894s]
    sending sparse ‘system’ (478340 KB)…

    #44930

    cblx5
    Member

    Hi, I found Nexus Root Toolkit (which I have used before for my Nexus 7) and after a bit of fiddling my Nexus 9 is fully booted up back to Android 7.1.1

    I cannot explain why one method worked and the other did not.

    Thanks for the tips.

    #44936

    cblx5
    Member

    update – I am now back to Stock Android 7.1.1 following advice from Shibaa987 on a related link above. I may reload linOS 15.1 shortly and will monitor linOS 16 development.
    Thanks

    #45060

    shibaa987
    Participant

    I will update if there will be some new build of LineageOS 16 for Nexus 9.

    #46126

    n o l o n
    Member

    Ok I fixed encryption by factory reset after instal ROM and gapps (this is important step or u will have encrypted tablet), but after few second tablet freeze :/ I can’t fix it and I think we need to wait new build (I hope there will be new build)

    #48686

    xmsz
    Member

    Any update?

    #49076

    pizted
    Member

    Do not use this image! It’s broken. To all effects, the touchscreen driver doesn’t work and there are rendering issues, that leaves the device useless. For the encryption problems, the only workaround is doing a factory reset on TWRP *but* be careful, that will delete your images as well.

    If you find yourself with a blank device (all but TWRP, like @cblx5) follow these steps:

    – Activate ADB Sideload on TWRP
    – Confirm that the device appears in ADB
    – Deactivate ADB Sideload
    – Use ADB to copy a new ROM onto the device to flash.

    That should do the trick.

    #53360

    to fix ask passsword and encryption you need to edit fstab.flonder in this way

     

    /dev/block/platform/sdhci-tegra.3/by-name/UDA /data f2fs noatime,nosuid,nodev,errors=panic wait,check,latemount,encryptable=/dev/block/platform/sdhci-tegra.3/by-name/MD1
    /dev/block/platform/sdhci-tegra.3/by-name/UDA /data ext4 noatime,nosuid,nodev,nomblk_io_submit,errors=panic wait,check,latemount,encryptable=/dev/block/platform/sdhci-tegra.3/by-name/MD1

     

    you nedd to chage forceencrypt mount option on encryptable

     

    for hwcomposer issu i can check @HashBang can you cntact me on hangouts as davide.franzino@gmail.com ?

    #54248

    iason stv
    Member

    @shibaa987 are you planning on updating this rom? Great work getting it to boot, tho there are several issues, the biggest one being when using the touch screen, the tablet freezes after some seconds, a workaround is to use a mouse over otg. Wifi and bluetooth are aswell non functional 🙁

    1

    2

    3

 
 
Viewing 10 posts - 11 through 20 (of 26 total)

You must be logged in to reply to this topic.

   
Loading...