Nexus 4 CM14/14.1 (CyanogenMod 14/14.1, Nougat 7.0/7.1 ROM)

Home Forums Google Nexus 4 – Mako Nexus 4 CM14/14.1 (CyanogenMod 14/14.1, Nougat 7.0/7.1 ROM)

This topic contains 14 replies, has 3 voices, and was last updated by  shibaa987 1 month, 2 weeks ago.

  • Author
    Posts
  • #7379

    Android Nougat 7.0 ROM, Nexus 4 CM14/14.1 (CyanogenMod 14/14.1). This Nougat 7.0 has come for Nexus 4 CM14/14.1 (CyanogenMod 14/14.1) ROM and we also have the official CM14.1 for Nexus 4, which you can check out. We have update many Android NOUGAT AOSP ROMs and also many CM14/14.1 (CyanogenMod 14/14.1) ROMs updated and many are yet to come. We also have the AOSP Nougat 7.0 for Nexus 4 (mako) and now this CyanogenMod 14/14.1 (CM14/14.1) for Nexus 4 (mako) is brought to you by developer StephanMc.

    If you liked his work and want to help him keep developing stuffs like this then you can Donate him via PayPal using this link.

    DISCLAIMER:
    THIS IS AN INITIAL BUILD. THIS MAY NOT BOOT AT ALL OR IF IT BOOTS IT MAY HAVE MANY MORE BUGS THAN YOU CAN IMAGINE. TRY AT YOUR OWN RISK. Installing a custom ROM on a Nexus 4 requires the bootloader to be unlocked on the Nexus phone, which may VOID your warranty and may delete all your data. Before proceeding further you may consider backup all data on the phone. You are the only person doing changes to your phone and I cannot be held responsible for the mistakes done by you.

    Status of CM14 for Nexus 4 CM14 /CyanogenMod 14 Nougat 7.0 ROM:

    WHAT’S WORKING:
    – Network
    – Root
    – Wifi
    – Bluetooth
    – Audio
    – Camera
    – Video
    – USB
    – GPS
    – Sensors
    – Many more
    KNOWN ISSUES:
    – Nothing

     

    For more details of the working and non-working status of Nexus 4 CM14.1 OFFICIAL NIGHTLY ROM you can have a look on the following video:

    CM14 for Nexus 4 CM14/14.1 (CyanogenMod 14/14.1) Nougat 7.0 ROM

    REQUIRED LINKS AND FILES FOR NEXUS 4 CM14/14.1 (CyanogenMod 14/14.1) NOUGAT 7.0 CUSTOM ROM:

    HOW TO INSTALL/DOWNLOAD/FLASH/UPDATE CM14 FOR NEXUS 4/CYANOGENMOD 14 NOUGAT 7.0 CUSTOM ROM:

    1. Follow this if you are flashing CyanogenMod 14/14.1 (CM14/14.1) for Nexus 4 for the first time, or coming from another ROM:

      This will delete all your data on your phone. You may consider backing up your phone data or take a nandroid backup. Here is how to take NANDROID backup using TWRP recovery.

      Points to NOTE:
      – Try to avoid restoring apps backup using Titanium Backup. It may break things up.
      – Don’t restore system data using Titanium Backup! It will definitely break the current installation.
      – It is also discouraged to Restoring Apps + Data using Titanium Backup.

    2. Upgrading from earlier version of CyanogenMod 14/14.1 (CM14/14.1) for Nexus 4:

    Complete the initial setup and enjoy Android Nougat 7.0.0 with CyanogenMod 14/14.1 (CM14/14.1) for Nexus 4. After the installation of CyanogenMod 14/14.1 (CM14/14.1) for Nexus 4 you may want to enable ROOT access on your phone and here is how you can do that:
    How to Enable ROOT on CM14/14.1 (CyanogenMod 14/14.1).

    Stay tuned or Subscribe to the Nexus 4 (mako) forum For other Android Nougat ROMs, CyanogenMod 14 ROMs, other ROMs and all other device specific topics.

     

    Development thread for Nexus 4 CM14/14.1 (CyanogenMod 14/14.1) Nougat 7.0 ROM by StephanMc is here.

  • #7511

    It basically works, but the two most important apps (Telephone and Camera) consistently crash.

    Admittedly, I did steps d and e in one step (without rebooting into recovery mode after installing CM14).
    Also, I’m not sure if I understood the sentence “Wipe data factory reset, Cache partition, Dalvik Cache and Format the System partition.” correctly.

    Fortunately, I was able to restore the NAND backup 🙂

    • #7525

      Can you try with the latest ROM update and let me know how it went?

      Also I have updated the “Wipe data factory reset….” sentence to a meaningful one.

  • #7512

    Well, it basically worked for me – except that the telephone and camera apps crash consistently.

  • #7541

    OK, I tried a second time.
    This time I rebooted after installing CM14 with TWRP and before installing OpenGApps.
    And now everything seems to work perfectly.

    Thank you StepanMC!

  • #7542

    Update: Video recording is not working – neither 1080p nor 702p.

    • #7869

      Hi Henning, can you try the video recording with some third party camera apps?

    • #7902

      I tried with OpenCamera – the same effect. Taking photos is working, but video recording stops immediately with an “unknown error”. The app’s about dialog says “Last video error: error_268435556_-1007.”

  • #7854

    I’m not sure if this is related to the ROM, but today I tried making a call over Bluetooth for the first time. It consistently falied with an error message “Kein Netz” (no network). However, making a call without Bluetooth and the Bluetooh pairing DO work.
    I’m a Java developer, but not on Android. Can I help debugging the video an BT call issues somehow?

    • #7903

      At least, the BT call problem seems to be unrelated to the ROM 🙂
      Today I made a few calls over BT without any problems. Looks like yesterday it was actually a network problem…

  • #7904

    This might be just coincidence, but adb does not work:

    adb devices will never show the device, while the MTP driver is working, e.g. I can move files from and to the device using the windows explorer.

    But this might be a Windows 10 related problem. The last time when I used adb (before updating the ROM), I used a Linux PC.

    I already tried several tips from the internet, but none helped.

    • #7927

      Cna you try with a Linux machine and confirm if things are not broken because of this ROM?

    • #7950

      adb works fine on my old laptop with Ubuntu 14.04 LTS.
      But on Windows 10, no chance.

      At least now I’m sure that this issue is not related to this ROM.

      I wonder why everything works out of the box on Linux while things are so complicated on Windows.
      I remember this was the other way round 10 years ago…

  • #8081

    I have installed both ROM and GAPPS Aroma with excluding many apps except launcher due to insufficient storage problem. But all went sucess. Now I am not able to come out of TWRP screep.
    Each time i try to reboot in (SYSTEM, BOOTLOADER, RECOVERY) it just come inside TWRP.

    Please help.

    • #9908

      I have a Nexus 4 and the same happened with me. Recently I updated the official NIGHTLY OTA (manually) and after that somehow TWRP was just preventing the phone to boot. I broke my head, wiped data, system, reflashed ROM, bla bla and done tons of things but no success at all.
      Finally I just flashed the cyanogen recovery and to my surprise it started booting to the system. I took the cyanogen recovery from this link: http://www.cyanogenmods.org/forums/topic/official-nexus-4-cm14-1-cyanogenmod-14-1-nougat-7-1-rom/

      Try and let me know how it went.

  •  

You must be logged in to reply to this topic.